I believe in Hyper-V!

TFS 2015 Update1 post migration [Build machines]

Hi there,

Few days ago I migrated TFS2013.3. to TFS2015.1 on a new hardware. After migration I had few things to edit. Among other things I had to delete and edit cache in the TFS Build machines because they have not upgraded.

I made two changes on the build machines.

1. Unregister old TFS and register the new one. Simple as that!

2. Delete / edit TFS build machine cache! What happens if we don’t change these parameters?

Warning/error:

C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v14.0\BuildInfo\Microsoft.VisualStudio.ReleaseManagement.BuildInfo.targets (147): Unable to connect to the remote server. [C:\build\BizDataXMasterVS2015\STF\BizDataXDesignComponents\DataMasking.Common\DataMasking.Common.csproj]”

“C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v14.0\BuildInfo\Microsoft.VisualStudio.ReleaseManagement.BuildInfo.targets (147): Following information could not be added to build information because there was an error while communicating with TFS: ProjectItemSpec. Error: TF400324: Team Foundation services are not available from server https://oldtfsservername.domain.name:8088/tfs/defaultcollection. [C:\build\BizDataXMasterVS2015\Monitor\Xml2Report.Converter\Xml2Report.Converter.csproj”

What we need to do?

Logon to TFS build machine, open Windows Explorer, select Show hidden files, folders and drives.
image

Browse to “C:\Users\loggedinuser\AppData\Local\Microsoft\Team Foundation\5.0”
Open Cache folder and delete every file/folder from that.
image
image

After that open Configuration –> Version Control folder and open LocalItemExclusions.config file with a notepad

image
image

Change old TFS name with a new one! After that you can do build without warnings and errors.

Cheers.

Romeo

TFS 2015.1 upgrade/migration error [End of Central Directory record could not be found]

Hi there,

Few days ago I had a opportunity to upgrade/migrate production TFS 2013 Update 3 to TFS 2015 Update 1. The migration process is “straightforward” but as usual every time something goes wrong. Unfortunately, this time I didn’t have exception Smile.
As I mentioned above, we had TFS 2013.3 but it wasn’t a clean installation, that was an in-place upgrade from TFS 2008 –-> 2010 –> 2013 in the last couple of years. This time I decided to do upgrade to the new hardware.

Here I’ll not explain how to migrate, I want to explain what type of error I had and how solve problem.

During the upgrade process I got error and warning…
[2016-02-15 20:13:22Z][Error] End of Central Directory record could not be found.
[2016-02-15 20:13:19Z][Warning] Invalid zip file in process template MSF Agile For Project Server 2007, End of Central Directory record could not be found.
[2016-02-15 20:13:20Z][Warning] Invalid zip file in process template MSF CMMI For Project Server 2007, End of Central Directory record could not be found.

image

When you try to find resolution on the Internet you will find NOTHING! But luckily error is obvious. We need to delete problematic Process Templates. Open Process Template Manager from the Visual Studio, find the problematic templates and delete them.

image
image

When you are done, have to repeat whole procedure. Backup databases, restore, upgrade… and at the end you will have successful TFS upgrade Winking smile

Thank you Ognjen for your precious help Smile

Cheers

Romeo

WEBINAR: Troubleshooting Microsoft Hyper-V – 4 Tales from the Trenches

Join to this amazing webinar organized by Altaro Software. In this webinar you’ll learn Hyper-V troubleshooting basics and solutions to common problems represented by Andy Syrewicze (@asyrewicze) and Didier van Hoye (@WorkingHardInIT)

Sign up now to join us on February 25th, 2016 at 4pm CET / 10am EST
(30-45mins + live Q&A!) for some tales from the trenches!

Sign up here:

webinar-Join-button-troubleshooting-hyperv